frame

Motor Adım Sayısını Değiştiremiyorum

said63ksaid63k Yeni Üye
kategorisi Yazılım
Konuyu inşallah doğru yere açmışımdır.
Sunhokey Prusa ı3 Cihazım var extuder testi yaptım 100 gönderdim 70-80mm ilerledi daha sonra repertier programı üzerinden EEPROM yazılım yapılandırma ayarından gerekli düzenlemeyi yapacaktım yalnız o ayar programda kapalı giremiyorum. biraz araştırdım marlin le alakalı bişeymiş (Marlin Firmware terimlerinin ne olduğunu bilmiyorum acemiyim biraz) Cihazın LCD üzerinden yapılıyormuş Menu-Control-Motion yapıp aşagıda E motoru için değeri artırıp tekrardan test yaptım düzeldi ama sıkıntı ayarı kaydedemiyorum bilgisayara bağlanınca veya yazıcıyı kapatıp açınca tekrardan eski ayara dönüyor ne yapmalıyım.

ilgili videolar:
https://www.youtube.com/watch?v=SDvz2GTSSJg
https://www.youtube.com/watch?v=ckP2-GrMHvA (ıngilizce Olduğu için bişey anlamadım ama konuyla alakalı)
https://www.youtube.com/watch?v=LOdYbRoMTmg (Benim yazıcı)

Yorumlar

  • ta1drta1dr Bilir Kişi
    merlinde sanırım fw den düzeltmek en dogrusu...
    normalde M500 yada M501 kodları ile yapılıyor diye yazıyor ama nedense bende yapamamıştım
    repetier en iyisi ...
  • said63ksaid63k Yeni Üye
    ta1dr yazdı: »
    merlinde sanırım fw den düzeltmek en dogrusu...
    normalde M500 yada M501 kodları ile yapılıyor diye yazıyor ama nedense bende yapamamıştım
    repetier en iyisi ...

    hocam repertierden yapmak istiyorum resimde göründüğü gibi sekme klitli
    http://i.hizliresim.com/BPP3jD.jpg
  • Hocam repetier fw kullanmadım ama belki yazıcıyı bağlamamadığınız için o sekme açılmıyor olabilir. Ya da repetier fw oluşturulurken belki bu bölüme izin verilmemiş olabilir.


    Sent from my iPhone using Tapatalk
  • said63ksaid63k Yeni Üye
    Hocam repetier fw kullanmadım ama belki yazıcıyı bağlamamadığınız için o sekme açılmıyor olabilir. Ya da repetier fw oluşturulurken belki bu bölüme izin verilmemiş olabilir.


    Sent from my iPhone using Tapatalk

    yok hocam herşeyi denedim. üretici yazılımı değiştirmemek üzere atmış heralde tek aklıma gelen bu. yeni marlin felan atılması lazımmış o konuyuda bilmiyorum :)
  • ta1drta1dr Bilir Kişi
    arduino mega yok mu üzerinde ona repetier firmware yükleyeceksin bu dertlerden kurtulacaksın...
    yada üretici ile görüşmekte fayda var.
  • oceanssouloceanssoul Yeni Üye
    Marlinde

    #define DEFAULT_AXIS_PER_UNIT {..., ..., ..., 150}

    yazan satırı bulup 150 değerini artırarak deneme yap. Doğru miktarı itene kadar devam et.



    GT-I9300 cihazımdan Tapatalk kullanılarak gönderildi
  • said63ksaid63k Yeni Üye
    oceanssoul yazdı: »
    Marlinde

    #define DEFAULT_AXIS_PER_UNIT {..., ..., ..., 150}

    yazan satırı bulup 150 değerini artırarak deneme yap. Doğru miktarı itene kadar devam et.



    GT-I9300 cihazımdan Tapatalk kullanılarak gönderildi

    Hocam yaptım sonuç olarak değer değişiyor cihazın üzerindede değer değişiyor ama işleve geçmiyor eskisi gibi 100mm gönderiyorum 80 ilerliyor. acaba başka bi sorun olabilirmi motor akımında felan.
  • ta1drta1dr Bilir Kişi
    bu işlemi ekranda değil yazılım kodlarında yapman lazım (firmware de)
    said63k nında yazdıgı gibi kodlarda değişikliği yapıp compile edip arduinoya yüklemen lazım

    eger evet koblarda yapıyorum düzelmiyor diyorsan hesaplamada hata yapıyor olmayasın veya host program üzerinde flowrate %100 olmalı bun degerden düşük olmamalı...
  • said63ksaid63k Yeni Üye
    ta1dr yazdı: »
    bu işlemi ekranda değil yazılım kodlarında yapman lazım (firmware de)
    said63k nında yazdıgı gibi kodlarda değişikliği yapıp compile edip arduinoya yüklemen lazım

    eger evet koblarda yapıyorum düzelmiyor diyorsan hesaplamada hata yapıyor olmayasın veya host program üzerinde flowrate %100 olmalı bun degerden düşük olmamalı...

    hocam hesaplamalarım doğru şöyle söylim: 100mm gönderiyorum 80 gidiyor arduion daki değer 80.5
    100mm gönderdiğimde 100mm gitmesi için ayarı [(80,5*20)/100]+80,5=97,4 çıkıyor bilgisayardan yazılım üzerinden 80,5 olan değeri 97,4 yapıp karta yüklüyorum. daha sonra yazıcıdan da bakıyorum (Menu-control-motion-en alttaki değer e motorunun adım sayısı:97,4 oluyor) yazıcıyı kapatıp açıncıda değişmiyor. daha sonra tekrardan test yapıyorum ama hala sıkıntılı. ''host program üzerinde flowrate %100 olmalı'' derken neyi kastettiğini anlamadım.
  • ta1drta1dr Bilir Kişi
    anladığım kadarıyla arduino ide den firmware müdahale edebiliyorsun ve karta yüklüyorsun
    ama ozaman yeni değerin değişmemesi lazım
    akla merlin sıkıntılı diyesim geliyor
    uzun süre merlin kullanıp sonra repetiere gecen biri olarak ısrarla repetiere geçmeni tavsiye ederim...
  • hacibothacibot Abbas Geliştiricisi
    Kasnaklar Gt2 mi T2,5 mu _?
  • said63ksaid63k Yeni Üye
    hacibot yazdı: »
    Kasnaklar Gt2 mi T2,5 mu _?

    hocam T2.5
  • said63ksaid63k Yeni Üye
    ayrıca

    // EEPROM
    // The microcontroller can store settings in the EEPROM, e.g. max velocity...
    // M500 - stores parameters in EEPROM
    // M501 - reads parameters from EEPROM (if you need reset them after you changed them temporarily).
    // M502 - reverts to the default "factory settings". You still need to store them in EEPROM afterwards if you want to.
    //define this to enable EEPROM support
    #define EEPROM_SETTINGS
    //to disable EEPROM Serial responses and decrease program space by ~1700 byte: comment this out:
    // please keep turned on if you can.
    #define EEPROM_CHITCHAT

    //#define EEPROM_SETTINGS
    //#define EEPROM_CHITCHAT

    bu satırlar kapalıydı

    #define EEPROM_SETTINGS
    #define EEPROM_CHITCHAT

    açtım menüye store ve load menüleri geldi sorunlar çözülmesi gerekiyor normalde ama niye 100 mm gönderince 100mm ilerlemiyor aklıma 2 farklı sınıtı geliyor ya motor sürücü akımla ilgili bişey yada nozule den alakalı bişey diye düşünüyorum
  • hacibothacibot Abbas Geliştiricisi
    T2,5-16 diş ise 80 olucak 1/16 stepte.
  • hacibothacibot Abbas Geliştiricisi
    Kartın MKS GEN V2 . Aurdino + Ramps birleşimi . Sürücü bozuk yada step ayarın çalışmıyor olabilir.
  • said63ksaid63k Yeni Üye
    sıkıntı çözüldü yazılımdan ta1dr nin söylediği gibi gerekli düzeltmeleri yaptım herhey tıkırında. yalnız hotend kısmında bir sıkıntı var benim yazıcı bowden iletim yapıyor. hotende giren kısımdan filamenti çıkarıp öyle test ettim herşey güzel. hotend kısmını değiştirmek istiyorum şuan. direct drive çevirimmi yoksa böyle kalıpta kaliteli bir hotend mi almalıyım sizce.
  • hacibothacibot Abbas Geliştiricisi
    ıptal et bowdeni , En iyisi direct drive.
  • said63ksaid63k Yeni Üye
    bi tasarım görmüştüm thingiverse bayağı baktım bulamadım. acaba stl dosyalarını nerden bulabilirim. bide o tasarıma uygun bi hotend önerebilirmisiniz. yanlız yapılan tasarımda arka düz kısmı millere geçen kısımda lme88u rulman kullanılması gerekiyor onun yerine benim makınanın üstündeki rulmanları ve rulmanların takıldığı düz fiberglası kullanabilirmiyim acaba.

    tasarım: http://i.hizliresim.com/nMj9W0.jpg
    benim makına http://i.hizliresim.com/Pkn2D5.jpg
  • hacibothacibot Abbas Geliştiricisi
    Üsteki wade , altakini bilmiyorum.
    http://www.thingiverse.com/thing:18379

    WAde , greg wade diye arat
  • OsmanOsman Yeni Üye
    Eğer kontrol kartı mega ve ramps ise yazılımı değiştirmek kolay
    yazıcıyı bilgisaya bağlayıp bu videyodakı gibi ayarları yaparsan sorunu hall ede bilirsin
    https://www.youtube.com/watch?v=iKTVjWAnENs
    bu siteden de gerekli bilgileri girip uygun rakamı bulup X, Y, Z "step per mm" için gire bilirsin
    http://prusaprinters.org/calculator/

Bir Yorum Bırak

Görsel/dosya bırak

3d Yazici Destek

| 3d Yazıcının kalbi burada atıyor
3d Yazıcı Destek© 2017 | 3d yazıcılar hakkında herşeyi bulabilceğiniz, ücretsiz yardımlaşma ve dayanışma forumudur.
Powered by VanillaForums, Designed by Raven Creativity

İletişim

info@3dyazicidestek.com
3dyazicidestek@gmail.com
0 505 948 47 57

Get In Touch